Adventure Driven Talk

Tech Questions and How-To Articles => Mitsubishi Related => Gen 2 Montero => Topic started by: DR1665 on February 04, 2019, 08:43:33 PM

Title: Tach mostly dead
Post by: DR1665 on February 04, 2019, 08:43:33 PM
Noticed Fezzik's tach wasn't working one morning. Gave it a smack and it started working again. Made me laugh.

But it's largely dead now all the time. Seems like it works less than 10% of the time. Bummer.



I pulled the cluster disconnected and reconnected the harness, hoping a simple reseat would do the trick, but all I got was some really clean gauge faces.

Truck runs fine otherwise. CEL is back recently, but I suspect it's a dying cat.

Any ideas? Suspect it's just s loose connection. I'm comfortable disassembling the cluster, but not looking to do any blind exploratory stuff right now.

Thanks.
Title: Re: Tach mostly dead
Post by: Shovel on February 05, 2019, 10:07:03 AM
This might help - http://www.pocuk.com/forums/viewtopic.php?t=111538&sid=92986

You can do this.   Or if you prefer come by my house some time and we can try to poke it like chimpanzees together. 

Title: Re: Tach mostly dead
Post by: DR1665 on February 05, 2019, 10:54:58 AM
Ooh! Good find. 32AWG conductors losing contact behind the gauge face? Seems as good a target as any. I'll see what I can do.

Thanks, buddy. I'd searched for NL Pajero tach problems, myself, but was down rabbit holes about PTU and resistors.

Will advise. Likely get our own pictures...
Title: Re: Tach mostly dead
Post by: RyanY on February 07, 2019, 04:48:23 PM
I've got a similar issue with my 95, although mine is still working around 70% of the time. Anxious to see what you discover.
Title: Re: Tach mostly dead
Post by: DinoDNA on March 01, 2019, 10:50:08 AM
I went ahead and replaced my 95 LS tach with one from a 2.5 cluster that plugged in a worked fine, i also have a spare 95sr cluster with same issue so i might pull its tach and see if it had the same contact issue.
Title: Re: Tach mostly dead
Post by: Shovel on March 01, 2019, 11:07:17 PM
https://www.yoycart.com/Product/537894589532/
Title: Re: Tach mostly dead
Post by: Drew84 on April 01, 2019, 09:05:50 AM
My tach has pretty much died and my fuel gauge is now on it's way out. I've been running a Scan Gauge plugged into the OBD port to monitor fuel consumption and RPMS.

But I would like to figure out the tach.