Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - radar56

Pages: [1]
1
Gen 2 Montero / Fuel Tank/Pump
« on: December 19, 2019, 05:24:04 PM »
Anyone know where I could look into getting a new tank and maybe pump assembly.  Engine has been running a little rough and was going to check the fuel filter, turns out that isn't going to happen being the pump bolts are never coming out.  The lines look like they could go anyday as well.  Got to love MN!

2
Gen 2 Montero / Re: Intake Manfold Vacuum Leak
« on: October 14, 2019, 02:50:57 PM »
Ended up pulling her apart and found an o-ring that fit.

3
Gen 2 Montero / Intake Manfold Vacuum Leak
« on: September 30, 2019, 06:12:06 PM »
Anyone every rebuilt the intake manifold on a 3.5?  Mine appears to have a pretty bad vacuum leak on the front where the butterfly valve leakage is.  I can hear the leak it is so bad...

Thanks

4
Gen 2 Montero / Electric Door Lock Issues
« on: August 09, 2019, 07:22:17 AM »
Recently the door locks started acting weird on the Montero.  Everytime I unlock the doors with either the key fob or the door switch it locks again right away.  I know the system is setup if you unlock it with your key fob and the door is not opened in 30 secs the doors relock.  To me it is acting like the system clock for that safety feature is not working as intended.  Anyone every have this issue before?  I am thinking the likely fix is to buy an aftermarket system, I think there is a link on here for a pretty cheap and easy on to install.  Maybe buy a remote start while I am at it...

Thanks

5
Gen 2 Montero / Re: Transfer Case Issues
« on: July 16, 2019, 11:23:23 AM »
I think the center diff was not locking in the Lc position at first.  Everything seems to be working now.  I know another guy around here who had his not locking as well, he did some digging and said if they sit for a while there can be some oil sludge that forms causing the diff to not lock, my rig was in storage for 10 years before I bought it.  After you try it a few times it works.  I am guessing that was my problem.

6
Gen 2 Montero / Re: Transfer Case Issues
« on: July 08, 2019, 07:18:58 PM »
OK...  So this is where I feel like a moron, but not completely.  Everything works as it should once I lock the front hubs in.  Why would that matter?  There must be something mechanical that doesn't lock in completely when the front drive shaft is not spinning. 


7
Gen 2 Montero / Re: Transfer Case Issues
« on: July 08, 2019, 06:12:12 PM »
It is a 1994 Montero SR.  Pulled the fill plug in the T-case and a bunch of oil poured out.  Figured I will change the oil as long as I am digging in there.

8
Gen 2 Montero / Re: Transfer Case Issues
« on: July 02, 2019, 11:37:12 AM »
I would say it shifts positively into gear.  I am out of town for the holiday but will dig into it more next week.  Start with the simple stuff: fluid, linkages etc...

Does anyone have a good layout of what the internals look like in these things?  I have not seen inside the Mitsu T-cases before. 

9
Gen 2 Montero / Transfer Case Issues
« on: July 01, 2019, 07:39:07 PM »
Was out driving today and happened to try putting the T-Case into 4wd. When it is in any of the 4wd modes the T-Case slips. Everything is fine in 2wd, but in 4wd I get little to no power to the ground...  Going to investigate some more hopefully tomorrow. Any thoughts on where I should start.

10
Gen 2 Montero / Re: New to Me 1994 Montero SR
« on: January 31, 2019, 09:22:38 AM »
Update on the '94.  Wanted to do valve stem seals before I started driving it.  Ended up pulling the cylinder heads to make the job easier and I had some concerns with 50% leak down on one of the cylinders.  Starting to go together now.



Some video of the ATF I drained from the truck after it has been outside here in MN for two weeks.  It was -32 when I left for work this AM...
https://youtu.be/KJzt6wxcENQ

11
Gen 2 Montero / Re: New to Me 1994 Montero SR
« on: January 15, 2019, 10:17:16 AM »
Also thought of this one, does the rear locker not work when there is an ABS fault?  I was playing for a minute while moving it from the trailer to the garage and couldn't get it to engage.

12
Gen 2 Montero / New to Me 1994 Montero SR
« on: January 15, 2019, 08:31:13 AM »
Picked up a 1994 Mitsu Montero SR yesterday.  105k and minimal rust, which is huge up in MN.  Working on getting her a runner again, been sitting in heated storage for 10 years...  Vale stem seals, timing belt, all new fluids etc...



While digging into her last night there is a code 32 for the ABS.  I dug down and was trying to find the G-Sensor and here is what I found under the center console.  I think the G-Sensor is missing...  What about the other connectors?


Also found the original tool kit is all intact, the 5 year old thought that was pretty cool.  I thought it was cool that the flashlight still had the battery isolator paper still in it.



Pages: [1]