Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - bpw

Pages: [1]
1
Gen 2 Montero / Starter solenoid access
« on: August 26, 2019, 10:02:44 AM »
I'm not near my Montero so can't check easily, but how easy is it to replace the starter solenoid vs. doing the entire starter?

I am getting occasional no start with a quiet click when I turn the key, then I turn the key a few times and all is good.  Thinking starter solenoid issue but if its just as much work to replace that as the whole starter I will put in a new starter, if the solenoid is easy I would rather do that first since starter looks like a hassle.  I am thinking the clicking I am hearing means its not the ignition switch, but could be wrong.  It sounds like some relay is engaging in the dash or hood, but much quieter than I would expect the main starter relay to be.  Only seems to happen on morning cold starts, no issue once the truck has been running a bit.  Battery is strong.

Thanks, I'm away from my truck for a few days and want to get parts ordered. 

2
Gen 2 Montero / ECU/TCU/check engine light
« on: December 23, 2018, 01:56:20 PM »
Hi,

1998 Montero 3.5 CA emmisions, non-winter package but I have added a factory locker set-up and control module.

Somewhat odd set of issues and looking for thoughts on things to check as well as info on the TCU/ECU computers.

For the last couple months I have been chasing a check engine light showing code P0400 "EGR A flow" and P1750 Solenoid assembly.  The EGR code has been coming and going for few months while the solenoid error is recent.

My mechanic has gone through the EGR system and can't find any issue with EGR valves or vacuum leaks.  After a reset it often takes 500-1000 miles before it turns on again and it seems to correlate with a drop in the idle speed.

The Solenoid error code started showing after the truck would not shift into overdrive one day.  Restarting the car fixed the overdrive issue and it has not recurred but the code comes back after a reset.

Mechanic says he is not getting good info when he hooks his code reader up and suspects it may be an issue with a flaky ECU or TCU.

I also get a very occasional no start where the engine will not crank and turning the key off and on again fixes the problem, no solenoid click when it happens and starter is strong when it does work.  Most likely unrelated starter issues, but not sure if it could be the security system telling the car not to start.

This make any sense?  Any thoughts?

What years ECU and TCU cross reference?  They are pretty cheap used so I may just get them to try.

3
Gen 2 Montero / Shift Kits
« on: October 13, 2018, 10:22:07 AM »
Am looking at getting a trans-go shift kit for my 1998 Montero, has anyone done and install and able to give an idea of how involved the process is?  Transgo doesn't seem to have installation instructions posted on the web anywhere.

Pages: [1]