Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - magoh

Pages: [1]
1
Gen 3 Montero / Re: 2003-2006 3.8 Timing belt and heavy maintenance list
« on: September 19, 2019, 07:37:40 AM »
Well crap, just saw the post about the forum closing.

2
Gen 3 Montero / Re: 2003-2006 3.8 Timing belt and heavy maintenance list
« on: September 18, 2019, 01:39:40 PM »
This is awesome. Is there a similar list for the 2001-2002 3.5?

3
Gen 2 Montero / Re: 1996 SR won't start
« on: October 29, 2018, 06:30:43 AM »
I appreciate your help. It ended up being the starter that was bad. Would still like to see your video about the in-dash voltmeter when you get it up.

4
Gen 2 Montero / 1996 SR won't start
« on: October 25, 2018, 10:27:53 PM »
My '96 Montero won't start. Gonna trailer it home tomorrow to look at it but doing some research in the meantime. Here's the symptoms, what do you think?

  • Doesn't crank.  Can sometimes hear a click inside the cabin when attempting to start but that's it. Had my dad helping and he thought he saw the belt turn a hair when attempting to start.
  • Voltmeter comes up to 12V very slowly when key is "on" position. If I wait for it to come up, then try to start, I hear more clicking, like if the battery was too low to start. However:
  • Interior and headlights come on and seem bright. but:
  • Plugged my OBDII reader in, but it won't power on even when key is in "on" position.
  • Jumping does no good, even if I leave the cables on for a long time.
  • The battery is about 13 months old.

Found some info in this thread I'm going to check into: https://forum.adventuredrivendesign.com/index.php/topic,363.0.html but if you have any other ideas that would be swell.

5
Mitsubishi Related / Re: Got a ticking sound?
« on: March 21, 2018, 06:45:22 PM »
Thank you Shovel and Funf. I remember reading this somewhere before but it's good to be reminded and to know it's an official procedure.

6
Gen 2 Montero / Re: Getting knuckle back on
« on: March 03, 2018, 09:42:55 PM »
Thanks for all the replies. I ended up loosening the torsion bar but as I was lifting the LCA the shock decided to dump it's oil  :-\ Guess I'll see if it's under warranty, just put these on a little less than 2 years ago. Although... Can I use the ADD Bilstein 5100s without a lift?

7
Gen 2 Montero / Getting knuckle back on
« on: February 28, 2018, 10:27:54 PM »
I re-booted my driver's side CV boots and while I was at it I replaced some other front end parts.  Now that I'm putting it all back together, I can't seem to lift the lower control arm up high enough before it starts lifting the truck.  I'm guessing I need to loosen the torsion bar or something like that but thought I'd ask the experts here first. Any hints?

Pages: [1]