Author Topic: I'm only getting lame aftermarket suspension parts for Gen 1 lately  (Read 1566 times)

KrzyDav

  • Member
  • Posts: 27
  • I'm new here!
I just received an idler arm with nylon insert lock nuts. It also was not the "555" unit in the net site photo. I'm planning o returning it. I don't trust nylon locknuts in such places.
A few months ago I kept getting and returning ball joints from local parts store. All Moog but each one was different. Nylon nuts, some with grease fittings. I finally got 2 with castle nuts.
I think it doesn't matter what brand you order, you'll get a brand logo box with the same un marked, un logoed part of unknown origin in the box.
I recon I just need to save up and et an EM idler. I have a Gen 2 idler on my Gen 1 but discovered that will not work without changing to Gen 2 steering box. That's beyod my budget and skills to go  that far with a mod I don't need. So I trying to goback to originaltype idler if I can find a decent one.

KrzyDav

  • Member
  • Posts: 27
  • I'm new here!
Re: I'm only getting lame aftermarket suspension parts for Gen 1 lately
« Reply #1 on: October 07, 2017, 11:36:07 PM »
 Thanks,,, I want it ... I  still have some leftover new OEM white  bushings for it. I'll send you a p.m.

Crumb

  • Member
  • Posts: 741
Re: I'm only getting lame aftermarket suspension parts for Gen 1 lately
« Reply #2 on: October 16, 2017, 04:35:22 PM »
 Rebuild the OEM idler with ADD kit and buy OEM ball joints and tie rod ends. That's the only way to fly.