Author Topic: New 97 SR with issues  (Read 2521 times)

MAV2.55

  • Member
  • Posts: 7
  • I'm new here!
New 97 SR with issues
« on: January 25, 2018, 04:40:29 PM »
Introducing my new to me 97 SR that I just bought this afternoon. It came with...good stuff and issues. I'll be updating progress as it happens, which will be slow. The truck cranks and fires but does not idle. Let the fun begin!

MAV2.55

  • Member
  • Posts: 7
  • I'm new here!
Re: New 97 SR with issues
« Reply #1 on: January 25, 2018, 04:51:33 PM »
Other known issues so far are that the door lock actuator(s) is not working, the cargo door outside handle does not work, the stereo is stuck on full blast, valve cover gaskets leak, and the a/c does not work.

MAV2.55

  • Member
  • Posts: 7
  • I'm new here!
Re: New 97 SR with issues
« Reply #2 on: January 29, 2018, 06:52:42 PM »
I got a little work done, and I do mean a little. I vacuumed the beast out as my three small boys will be using it as a fort. The radio now works as it should andI pulled the CEL codes. Looks like I have a misfire on cylinder 6, insufficient coolant temps, and a couple others. My next step is to check out fuel supply from the tank to the injectors. Cheers!

Crumb

  • Member
  • Posts: 734
Re: New 97 SR with issues
« Reply #3 on: January 30, 2018, 08:12:57 PM »
 So will it run with the throttle open?

MAV2.55

  • Member
  • Posts: 7
  • I'm new here!
Re: New 97 SR with issues
« Reply #4 on: February 13, 2018, 03:40:38 AM »
I finally got around to checking a few things out. Fuel pump works, fuel flows through the fuel filter. The truck will fire right up on starter fluid. I notice that every time I unscrew the fuel filler cap, even after just a few hours, that it releases pressure from the tank, making a hissing sound. Thoughts? Seems to me that the injectors may clogged or not firing.

MAV2.55

  • Member
  • Posts: 7
  • I'm new here!
Re: New 97 SR with issues
« Reply #5 on: February 13, 2018, 08:08:48 AM »
So will it run with the throttle open?
No sir. 

MAV2.55

  • Member
  • Posts: 7
  • I'm new here!
Re: New 97 SR with issues
« Reply #6 on: February 14, 2018, 02:08:22 PM »
I'm getting 4 different codes off the obdII. P0306 (misfire on 6), P0400 (exhaust gas recirculating flow) P0170 (fuel trim bank 1) and P0125 ( insufficient coolant temp for closed loop control).

PA_JERO

  • Member
  • Posts: 140
Re: New 97 SR with issues
« Reply #7 on: February 14, 2018, 06:46:16 PM »
On the no fire, injectors could be part of your problem, but maybe it could be the injection harness or possibly the ignition transistor. Check all plug connections first though. Coolant temp issue is likely just a temp switch above the thermostat housing. Exhaust gas flow could be a clogged or non working EGR valve.

Sounds like a lot of little things, hopefully nothing real major.

MAV2.55

  • Member
  • Posts: 7
  • I'm new here!
Re: New 97 SR with issues
« Reply #8 on: February 15, 2018, 04:18:01 PM »
The previous owner deleted the egr valve. I'll check the wiring around the injectors this weekend. Thanks!!