Author Topic: Weird water sound from the dash  (Read 444 times)

Tj90

  • Member
  • Posts: 3
  • Karma: +0/-0
  • I'm new here!
    • View Profile
Weird water sound from the dash
« on: March 01, 2018, 01:00:18 PM »
Hello all - I am the original owner of the 03 montero limited. In the last 4-5 months, I get this weird "water sound" from the dash. (I was hoping the other thread was related to my problem). Anyway, it usually happens when I am accelerating from a stop and does it more when the system is cold.

I was thinking that maybe it was the heater core, condensor core or the butterfly valve on the intake plenum. I cant find anyone else with this problem. It sounds like it is high in the dash toward the center.

Let me know if you experienced anything similar.

Regards,
TJ90

TOASTY

  • Member
  • Posts: 848
  • Karma: +34/-0
  • Nonsense, Poopy Pants!
    • View Profile
Re: Weird water sound from the dash
« Reply #1 on: March 01, 2018, 04:29:49 PM »
Did you do a coolant flush recently? Sounds like you have air in the system.

Tj90

  • Member
  • Posts: 3
  • Karma: +0/-0
  • I'm new here!
    • View Profile
Re: Weird water sound from the dash
« Reply #2 on: March 01, 2018, 09:53:15 PM »
Toasty - thanks for the suggestion. 4 months ago I replaced the coolant hose to the throttle body due to split hose. I had to add about a gallon of coolant from that fix. I wonder if I added air that is now trapped in the heater core or something?

Ive done plenty drain and fill coolant changes on this truck. Maybe its worth doing another to see if it changes the situation. Its cheap to try.

I had vapor lock in a heater core 30 years ago. The symptom was that the hot air would stop blowing hot after a short period of time. it was a pain to clear. I think it was basically run the heater on full blast for a long time. TIme to consult the experts on you tube!