Author Topic: brake blend proportioning valve...should I delete it?  (Read 633 times)

KrzyDav

  • Member
  • Posts: 28
  • Karma: +2/-0
  • I'm new here!
    • View Profile
brake blend proportioning valve...should I delete it?
« on: April 09, 2018, 10:56:35 PM »
I have a Gen 2 LS rear axle with disc , non abs , brakes installed in my '89 V6 raider that had drum rear brakes. I would like to know if the Gen 2 had a BLV. I read on an old WIRE post that the valve keeps slight pressure for brake cups. My rear pads wore out prematurely. I think maybe BPV is making them drag. Should I remove BPV???

MudRaider

  • Global Moderator
  • Member
  • Posts: 159
  • Karma: +7/-0
    • View Profile
Re: brake blend proportioning valve...should I delete it?
« Reply #1 on: April 10, 2018, 01:58:05 PM »
I've never ran that in any of my SWB, and never had an issue with brake pad wear.

TOASTY

  • Member
  • Posts: 848
  • Karma: +34/-0
  • Nonsense, Poopy Pants!
    • View Profile
Re: brake blend proportioning valve...should I delete it?
« Reply #2 on: April 10, 2018, 03:43:26 PM »
 I ran a proportioning valve on my LWB swaps but only because they had them, I didn't add one to my SWB trucks and was fine.

KrzyDav

  • Member
  • Posts: 28
  • Karma: +2/-0
  • I'm new here!
    • View Profile
Re: brake blend proportioning valve...should I delete it?
« Reply #3 on: April 10, 2018, 10:59:56 PM »
to be clear, my Raider came with the blend valve. It is located mid frame, drivers side on V6 (on 2.6 its under the hood). Seems I've heard that the  early Gen 2  non ABS doesn't have one. Also it seems that disproportionate more braking goes to the rear in panic braking ,,,happens frequently here as deer population is thru the roof.
« Last Edit: April 10, 2018, 11:05:13 PM by Dave Hild »

MudRaider

  • Global Moderator
  • Member
  • Posts: 159
  • Karma: +7/-0
    • View Profile
Re: brake blend proportioning valve...should I delete it?
« Reply #4 on: April 12, 2018, 11:50:16 AM »
I know what it is. All my SWB have LWB Gen 2 rear axles in them. So they all had them connected when I took them out of the donor vehicles. Just never put them on, as I asked about them when I first came across it, I was told it's more to assist with brakebias while towing. So I never bothered with it.