Author Topic: Gen 1 new oil pressure sending unit but faint check oil lamp. Stumped.  (Read 277 times)

so_ber

  • Member
  • Posts: 3
  • Karma: +0/-0
  • I'm new here!
    • View Profile
My first question to my fellow Montero appreciators is in regard to the oil pressure sending unit. The original one was kind of erratic, so the check oil lamp would come on sometimes. After reading many posts here and other forums/the internet it seemed the general consensus was to change it. I got the one for the gauge (as mine is a 1990 LS) and replaced it. I should tell you that when under the car in the limited space, I got a little disoriented so I initially tightened it a bit by accident. Rookie move. Got it off and the new one didnít want to go on at first. Had to find someone w/ a tap to neaten the threads a little. It finally went in and all seemed well. At night, though, I noticed the oil lamp was still glowing, very faintly. I took m/u car to a neighbor mechanic and had him check the oil pressure using a gauge. At idle it read just under 20 psi I think. Normal based on the readings others generally get. He put the sending unit back on and Iíve been driving it since, and during the day I canít see any light, but at night, itís always there. It sometimes gets slightly brighter, but never fully lit, itís on when the running lights are off. My oil pressure gauge usually reads about 30 psi (or just less), about 20 psi idling, and once in a long trip on a warm day it was lower (oil heated up?). Anyway, I changed it out about a month or two ago, and it has been the same ever since. Any thoughts??

DRLExpress

  • Member
  • Posts: 7
  • Karma: +1/-0
  • I'm new here!
    • View Profile
Re: Gen 1 new oil pressure sending unit but faint check oil lamp. Stumped.
« Reply #1 on: October 17, 2018, 08:15:22 AM »
Sounds like you got a sending unit for a gauge instead of a idiot light.
1989 Dodge Raider, 3.0, 5sp manual, LSD

so_ber

  • Member
  • Posts: 3
  • Karma: +0/-0
  • I'm new here!
    • View Profile
Re: Gen 1 new oil pressure sending unit but faint check oil lamp. Stumped.
« Reply #2 on: October 17, 2018, 09:05:39 AM »
Since my car has both (the idiot light and the gauge in the triple meter cluster), I got the one for the gauge. Hereís the link to the one I got:

https://shop.advanceautoparts.com/p/intermotor-oil-pressure-gauge-switch-s933/5972191-P?searchTerm=Oil+pressure

It says ďfor gaugeĒ.